Is it possible to alter the current behavior of scrolling

Hello, I’ve only recently discovered 010 Editor, I’m currently on the trial and I have to say I’m extremely impressed by how good it is compared to the freeware I was using. But one thing that I find very frustrating is that whenever you move your cursor to an area and scroll, it scrolls the selection rather than the scrollbar, as if you had pressed up and down on the keyboard.

I understand that this behavior can be useful in some scenarios, but I’m finding it really annoying personally. I might get used to it eventually, but I would be extremely grateful if an option could be added to change this behavior. As far as I can tell one does not currently exist.

I’m not asking for the default to be changed though, just for an option to be added to the preferences.

Hello Mikael. Thanks for your message. Yes, I completely agree that there should be an option to turn this off. There isn’t a way to disable it right now but we should be able to add that to our next release. Thanks for the feedback!

Graeme
SweetScape Software

1 Like

Thank you for the quick response. I’m really glad to hear that this feature will be added :smile:.
It was one of the only things that felt worse to me, compared to the editors I am used to using.

Thank you for all of the work you put into this program, It’s really impressive.

I may need examples of your scroll issue as I’m not seeing this.
I can select a block in a file and scroll down but the selection remains where I have it.

The behavior I’m referring to only affects side panes, not the main hex window. If you hover over the “Inspector” pane for instance and scroll you’ll find that the selected item in the pane changes rather than the scrollbar. The scrollbar only moves when your selection moves to an item that is offscreen. This is also the case with other panes like the “Template Result” pane which is honestly where I find it most annoying, as I’m dealing with structures with tons of elements.

This Gif illustrates the behavior I’m describing:

010Editor_kQudVSDKkJ

I’m not touching any buttons in that Gif, just scrolling the scroll wheel.

Thank You. I see what you are talking about now.

Can this please get addressed?

I’ve been using 010 since v3, and this has always driven me absolutely batty. Especially in the template results view, especially when creating and debugging templates. I go to see the results (and there are usually pages of results for what I do), look at a data member, then my muscle memory turns the wheel to scroll down in the results (which is the behavior of every other app I’ve ever used, ever), and it changes the selection… and every time I’m like, “ugh! I forgot about that!” And I have to go to the actual scroll bar on the right and surgically grab it, which I’m not good at because I’m not used to ever having to do that in any other app anywhere, ever. Even this window I’m typing in now - it scrolls with the mouse wheel; it doesn’t ‘select’ anything - it scrolls. The web browser I’m using to view this forum - the mouse wheel scrolls the page. It doesn’t select the elements in the page. :slight_smile:

Sorry if I’m coming across as whiny, but my goodness… how does a program as galactically awesome as 010 have such a silly design choice? And it really does interfere with my workflow. Looking at hex is a brain-intensive task. When I find a data member I’m looking for, and then highlight it and then go “ok, here’s the DWORD that does so and so… now what does the QWORD that does such and such say?..” and out of normal muscle memory I turn the wheel to scroll down to said QWORD in the results, and instead of doing what anyone would reasonably expect, it leaves my selected DWORD and highlights something else! Completely breaks my train of thought. I’m rambling…

But seriously though. Can you please change this, or at least give us the option to? Pretty please??

1 Like

Yes, we are planning on addressing this in our next version. There will be an option to turn this off and we are still debating about whether to turn off select-on-scroll by default. This has been a long-time 010 Editor behavior but it is different from other software so a lot of people have found it unexpected. The next version is coming along well and we’ll post a beta in the forum when we have it ready, hopefully in a few months.

Graeme
SweetScape Software

2 Likes

I’m putting my vote in here for this to be the new default behaviour—it’s something I simply cannot get used to and is never the behaviour I want. Every. time. I. scroll. the. template. results. It’s incredibly frustrating.